SD video playback issue

Post Reply
guzbox
Posts: 8
Joined: Tue Jan 19, 2010 1:07 pm

SD video playback issue

Post by guzbox »

Hello, I have Linux Mint currently installed and HD video playback works fine with mplayer-vaapi. My issue is dued to SD playback, if I try to play SD videos, even if h264 encoded, mplayer start displaying video artifacts, like squares or similar.
There's any solution for this problem?
Thank you

startit_ltd
Posts: 181
Joined: Thu Jul 23, 2009 7:18 am

Re: SD video playback issue

Post by startit_ltd »

Hi,

Use XV as output, instead of vaapi.
In console: mplayer -vo xv movie.avi
Or use Preferences if you use gmplayer.

Cheers,
István

guzbox
Posts: 8
Joined: Tue Jan 19, 2010 1:07 pm

Re: SD video playback issue

Post by guzbox »

Ok it works even if more cpu is required.
Is it a known limitation of current emgd driver?

Anyways I did a first workaround to use the right video output based on video resolution:
1-install mkvtoolnix

Code: Select all

sudo apt-get install mkvtoolnix

2-save this code in /usr/local/bin/FILENAME

Code: Select all

#!/bin/bash
resolution=$(mkvinfo "$1" |grep 'Pixel width'|awk '{print $5}')
case $resolution in
1920)
   smplayer -config-path /home/YOUR_USER/.config/smplayerHD "$1" &
   ;;
1280)
   smplayer -config-path /home/YOUR_USER/.config/smplayerHD "$1" &
   ;;
*)
   smplayer -config-path /home/YOUR_USER/.config/smplayerSD "$1" &
   ;;
esac

exit 0

3-make it executable

Code: Select all

sudo chmod +x /usr/local/bin/FILENAME

4-install smplayer if you don't

Code: Select all

sudo apt-get install smplayer

5-

Code: Select all

cp -r /home/YOUR_USER/.config/smplayer /home/YOUR_USER/.config/smplayerHD

Code: Select all

cp -r /home/YOUR_USER/.config/smplayer /home/YOUR_USER/.config/smplayerSD

6-edit /home/YOUR_USER/.config/smplayerSD/smplayer.ini and change "driver\vo=WHATEVER" to "driver\vo=xv" and "mplayer_additional_options=WHATEVER" to "mplayer_additional_options=-va vaapi"
7-edit /home/YOUR_USER/.config/smplayerHD/smplayer.ini and change "driver\vo=WHATEVER" to "driver\vo=vaapi" and "mplayer_additional_options=WHATEVER" to "mplayer_additional_options=-va vaapi"

End
Now you have to change your gnome settings to open video files with /usr/local/bin/FILENAME

Please let me know if you have any suggestions.

Post Reply

Return to “Linux Mint”