GPIO (leds) default values

Post Reply
paolodenti
Posts: 3
Joined: Tue Oct 15, 2019 12:43 am

GPIO (leds) default values

Post by paolodenti »

I have not found any setting in the UEFI to set the default value of LED 2 and 3 to off.

How can it be done?

Thank you

tamir
Site Admin
Posts: 419
Joined: Mon Dec 25, 2017 4:21 pm

Re: GPIO (leds) default values

Post by tamir »

Please find below manual for controlling the fitlet2 GPIO front LEDs:
http://fit-pc.com/wiki/index.php?title= ... front_LEDs

paolodenti
Posts: 3
Joined: Tue Oct 15, 2019 12:43 am

Re: GPIO (leds) default values

Post by paolodenti »

tamir wrote:Please find below manual for controlling the fitlet2 GPIO front LEDs:
http://fit-pc.com/wiki/index.php?title= ... front_LEDs
thank you Tamir, we are already using the gpio to control the LEDs.
However my question was related to the default value of the LED, the one set, I guess, by the firmware.

The LEDs, after power on, are ON by default and we would like to have them OFF.

tamir
Site Admin
Posts: 419
Joined: Mon Dec 25, 2017 4:21 pm

Re: GPIO (leds) default values

Post by tamir »

Unfortunately, it is not possible to control the default behavior from EFI.
This requires certain BIOS development as this feature is currently not available.

paolodenti
Posts: 3
Joined: Tue Oct 15, 2019 12:43 am

Re: GPIO (leds) default values

Post by paolodenti »

tamir wrote:Unfortunately, it is not possible to control the default behavior from EFI.
This requires certain BIOS development as this feature is currently not available.
Thank you Tamir

As a personal consideration, I think the default value should always be off.
If LEDs 2 and 3 are meant to be customized by the user, they are meant to go on whenever the user service is "ready/on/available" and that happens under some explicit actions; it does not happen when the board is booting.

Post Reply

Return to “fitlet2 hardware”