Ubuntu [lubuntu] / no sound over HDMI

Post Reply
ThatTallGuy
Posts: 6
Joined: Fri Dec 21, 2012 6:33 pm

Ubuntu [lubuntu] / no sound over HDMI

Post by ThatTallGuy »

Hi,
I've installed lubuntu 12.10 on my fit-pc3 and cannot get any sound over the HDMI port.
I see that the device is recognized -- aplay seems to work correctly (with -D hwplug:1,0) although no sound is heard.
Alsamixer reports all output values at 100% and unmuted. (Yes the TV volume is up high.)

Any suggestions?
--t

ThatTallGuy
Posts: 6
Joined: Fri Dec 21, 2012 6:33 pm

Re: Ubuntu [lubuntu] / no sound over HDMI

Post by ThatTallGuy »

More data, if it helps:
tdb@silent:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: SB [HDA ATI SB], device 0: ALC888 Analog [ALC888 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: SB [HDA ATI SB], device 1: ALC888 Digital [ALC888 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
tdb@silent:~$

ThatTallGuy
Posts: 6
Joined: Fri Dec 21, 2012 6:33 pm

Re: Ubuntu [lubuntu] / no sound over HDMI

Post by ThatTallGuy »

OK, revised question. Also a continuing document of where I am for future readers with the same problem.

First, thanks to this page (http://superuser.com/questions/53957/wh ... ich-to-use) I've learned about sound device aliases, which is good because after I posted the above I found that the command I had previously used didn't work anymore...

But the following command consistently succeeds:

Code: Select all

aplay -D plughw:CARD=Generic,DEV=3 <soundfile>


Which alias to use I determined by looking at the list of aliases given by aplay -L :

Code: Select all

tdb@silent:~$ aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
pulse
    PulseAudio Sound Server
hdmi:CARD=Generic,DEV=0
    HD-Audio Generic, HDMI 0
    HDMI Audio Output
dmix:CARD=Generic,DEV=3
    HD-Audio Generic, HDMI 0
    Direct sample mixing device
dsnoop:CARD=Generic,DEV=3
    HD-Audio Generic, HDMI 0
    Direct sample snooping device
hw:CARD=Generic,DEV=3
    HD-Audio Generic, HDMI 0
    Direct hardware device without any conversions
plughw:CARD=Generic,DEV=3
    HD-Audio Generic, HDMI 0
    Hardware device with all software conversions
default:CARD=SB
    HDA ATI SB, ALC888 Analog
    Default Audio Device
... and so on and so on...
 

And experimenting with each of the ones that showed HDMI in the paragraph.

So the resulting question is:
How do I incorporate the information that I *always* want any sound-generating program to use "plughw:CARD=Generic,DEV=3" as the sound device into an .asoundrc file?

gabrielh
Site Admin
Posts: 1260
Joined: Thu Jun 02, 2011 1:13 pm

Re: Ubuntu [lubuntu] / no sound over HDMI

Post by gabrielh »

To enable HDMI output on Ubuntu 12.10, try to install pavucontrol

Code: Select all

sudo apt-get install pavucontrol

and select appropriate profile under the Configuration tab.
Don't forget to reboot your system
Gabriel Heifets

Fit-PC2/3/IntensePC support.

ThatTallGuy
Posts: 6
Joined: Fri Dec 21, 2012 6:33 pm

Re: Ubuntu [lubuntu] / no sound over HDMI

Post by ThatTallGuy »

gabrielh wrote:To enable HDMI output on Ubuntu 12.10, try to install pavucontrol

Is pulseaudio required for HDMI audio? I don't currently have it running.

gabrielh
Site Admin
Posts: 1260
Joined: Thu Jun 02, 2011 1:13 pm

Re: Ubuntu [lubuntu] / no sound over HDMI

Post by gabrielh »

The pavucontrol will install all the necessary HDMI related libraries
Gabriel Heifets

Fit-PC2/3/IntensePC support.

ThatTallGuy
Posts: 6
Joined: Fri Dec 21, 2012 6:33 pm

Re: Ubuntu [lubuntu] / no sound over HDMI

Post by ThatTallGuy »

gabrielh wrote:The pavucontrol will install all the necessary HDMI related libraries


I have installed pavucontrol and it has not changed anything.

Previously, I could run

Code: Select all

aplay -D plughw:CARD=Generic,DEV=3 /usr/share/sounds/alsa/Front_Center.wav

And I got sound just fine, but other things didn't play because HDMI wasn't the default sound device. Now, after installing pavucontrol.... I still get sound with that command, and it's still not the default sound device. Trying to run pavucontrol gives me a message "Connection to PulseAudio failed."

I just want to tell alsa to use HDMI. How to do that?

gabrielh
Site Admin
Posts: 1260
Joined: Thu Jun 02, 2011 1:13 pm

Re: Ubuntu [lubuntu] / no sound over HDMI

Post by gabrielh »

You should choose one of the HDMI profiles in the Configuration tab
Gabriel Heifets

Fit-PC2/3/IntensePC support.

Post Reply

Return to “Linux on fit-PC3”