CentOS 6.2 doesn't automatically boot (grub)

Post Reply
matonb
Posts: 1
Joined: Tue Apr 10, 2012 10:52 am

CentOS 6.2 doesn't automatically boot (grub)

Post by matonb »

I just got a couple of Fit3's and have a problem with neither of them automatically booting (CentOS 6.2, 64 bit).

The grub menu appears and waits for a key press before continuing even though it's configured to auto boot after a 5 second timeout.

I have CentOS 6.2 (32 bit) working fine on another Fit2.

Anyone have an idea how to solve this. It's a real problem with a headless unit.

gabrielh
Site Admin
Posts: 1260
Joined: Thu Jun 02, 2011 1:13 pm

Re: CentOS 6.2 doesn't automatically boot (grub)

Post by gabrielh »

We haven't tested the CenOS on the FitPC3, maybe other users will kindly share their experience
Gabriel Heifets

Fit-PC2/3/IntensePC support.

nelg
Posts: 8
Joined: Mon Nov 14, 2011 8:57 pm

Re: CentOS 6.2 doesn't automatically boot (grub)

Post by nelg »

are you sure this is a hardware issue? I would think if you've got grub prompting for a key, as that point it would be a grub configuration issue.

koschate
Posts: 3
Joined: Thu May 10, 2012 6:46 pm

Re: CentOS 6.2 doesn't automatically boot (grub)

Post by koschate »

Has anyone gotten any further with this issue? I just got a bunch of fit-PC3s I want to install CentOS on, but this boot thing is a real problem. It works fine on a fit-PC2, and any virtual machine I've ever created.

koschate
Posts: 3
Joined: Thu May 10, 2012 6:46 pm

Re: CentOS 6.2 doesn't automatically boot (grub)

Post by koschate »

For whatever it's worth, setting the grub timeout to 0 results in the machine automatically booting into the default configuration. This isn't perfect, but it's much, much better than being stuck at the boot screen forever!

Arwen
Posts: 145
Joined: Sun Nov 20, 2011 10:43 pm

Re: CentOS 6.2 doesn't automatically boot (grub)

Post by Arwen »

You know, if a normal timeout like 10 seconds won't work and the
box is stuck, it's almost like Grub does not have a working timer.

If that is the case, it might be possible to re-compile Grub to use
a different timer. Even a simple software timer might be acceptable.
For example, if the serial port is not in use, you can set it to 1200bps,
parity and 2 stop bits. That ends up being exactly 100 characters a
second and suitable for sending out 1,000 characters for a 10 second
timeout.

In my case, it will probably be months before I purchase a fit-PC 3,
(my older fit-PC 1 works just fine). But when I do, it will be with
Linux, most likely Gentoo. So whatever solution you find, (besides
timeout of zero), will be useful.
Arwen Evenstar
Rivendale, Middle Earth

koschate
Posts: 3
Joined: Thu May 10, 2012 6:46 pm

Re: CentOS 6.2 doesn't automatically boot (grub)

Post by koschate »

If that is the case, it might be possible to re-compile Grub to use
a different timer.

In our case, and I suspect in a lot of places where there will be a large scale deployment of these units, this just won't fly. My marching orders are to keep the OS distribution as close to stock as possible. If I have to start the OS with a non-standard loader, I'm going to have a really tough time convincing folks that nothing else is affected.

banosr
Posts: 1
Joined: Wed Oct 17, 2012 8:00 pm

Re: CentOS 6.2 doesn't automatically boot (grub)

Post by banosr »

I have the same problem with elastix 2.3 on Centos 5.7, thankfully setting timeout to 0 works for me

rambler
Posts: 9
Joined: Sat Feb 06, 2010 1:22 am

Re: CentOS 6.2 doesn't automatically boot (grub)

Post by rambler »

Just received a new fit-PC3 to replace my old fit-PC2, installed CentOS 6.3 X86_64 and hit this same problem. Currently using the workaround of setting the delay to 0 but it's not ideal.

Post Reply

Return to “Linux on fit-PC3”