Fitlet mSATA Hard Drive not Recognized

Post Reply
mblake
Posts: 3
Joined: Mon Oct 30, 2017 3:15 pm

Fitlet mSATA Hard Drive not Recognized

Post by mblake »

I've been working with a bunch of Fitlet-i Barebone's. I've installed the same 64GB mSATA SSD on all of them, but some of them do not seem to recognize the drive. I boot into BIOS and see under SATA settings that the Internal SATA is marked as "not present". I have made sure that the drive is seated properly, and I have tested all the drives on working fitlets. It seems to be a problem with SATA port itself. After the first time I saw this, I was concerned that I had accidentally knocked a pin or something. I was very careful going forward when installing more hard drives, but the problem persisted.

Any thoughts? I want to see if there is a fix I can do myself before trying to get the units replaced.

irads
Site Admin
Posts: 2366
Joined: Mon Mar 16, 2009 2:11 pm

Re: Fitlet mSATA Hard Drive not Recognized

Post by irads »

Try installing without the mSATA heat-plate to ensure there is no excess mechanical pressure exerted.

You can even leave the bottom cover open when powering-up into BIOS.
-------------------------
Irad Stavi
Forum admin

-------------------------

mblake
Posts: 3
Joined: Mon Oct 30, 2017 3:15 pm

Re: Fitlet mSATA Hard Drive not Recognized

Post by mblake »

No dice. I tried it with a few different drives and devices, but it's still not seeing the SSD. Thanks for the suggestion.

If you have any other input, I'm happy to try anything. However, I'm probably just going to try to replace the units in the next few days if I don't get these ones working.

irads
Site Admin
Posts: 2366
Joined: Mon Mar 16, 2009 2:11 pm

Re: Fitlet mSATA Hard Drive not Recognized

Post by irads »

Apparently the SATA interface in the said fitlet unit malfunctions. Please consider RMA.
Sorry for the inconvenience.
-------------------------
Irad Stavi
Forum admin

-------------------------

Post Reply

Return to “Storage”